diff OrthancServer/CMakeLists.txt @ 5811:a451777236fb attach-custom-data tip

advanced storage: fix + customizable path
author Alain Mazy <am@orthanc.team>
date Tue, 24 Sep 2024 17:52:45 +0200
parents 023a99146dd0
children
line wrap: on
line diff
--- a/OrthancServer/CMakeLists.txt	Tue Sep 24 15:15:51 2024 +0200
+++ b/OrthancServer/CMakeLists.txt	Tue Sep 24 17:52:45 2024 +0200
@@ -825,6 +825,14 @@
     list(APPEND ADVANCED_STORAGE_RESOURCES ${AUTOGENERATED_DIR}/AdvancedStorage.rc)
   endif()
 
+  EmbedResources(
+    --target=AdvancedStorageDicomResources
+    --namespace=Orthanc.FrameworkResources
+    --framework-path=${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources
+    ${LIBICU_RESOURCES}
+    ${DCMTK_DICTIONARIES}
+    )
+
   set_source_files_properties(
     ${CMAKE_SOURCE_DIR}/Plugins/Samples/AdvancedStorage/Plugin.cpp
     PROPERTIES COMPILE_DEFINITIONS "ADVANCED_STORAGE_VERSION=\"${ORTHANC_VERSION}\""
@@ -832,13 +840,9 @@
 
   add_library(AdvancedStorage SHARED 
     ${CMAKE_SOURCE_DIR}/Plugins/Samples/AdvancedStorage/Plugin.cpp
-    ${ORTHANC}
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/OrthancException.cpp
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/SystemToolbox.cpp
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/Toolbox.cpp
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/Logging.cpp
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/ChunkedBuffer.cpp
-    ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources/Enumerations.cpp
+    ${CMAKE_SOURCE_DIR}/Plugins/Samples/AdvancedStorage/OrthancFrameworkDependencies.cpp
+    ${AUTOGENERATED_DIR}/AdvancedStorageDicomResources.cpp
+    ${ADVANCED_STORAGE_RESOURCES}
     )
 
   DefineSourceBasenameForTarget(AdvancedStorage)