diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 5357:fddb5d8d0021

Prevent the leak of the full path of the source files in the binaries
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 06 Jul 2023 17:04:31 +0200
parents 0ea402b4d901
children 78aad3916da4
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Tue Jul 04 18:39:52 2023 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Thu Jul 06 17:04:31 2023 +0200
@@ -305,6 +305,8 @@
     # plugins (the latter being shared libraries)
     set_property(TARGET OrthancFramework PROPERTY POSITION_INDEPENDENT_CODE ON)
   endif()
+
+  DefineSourceBasenameForTarget(OrthancFramework)
 endif()