diff OrthancServer/CMakeLists.txt @ 4979:f316413027fd more-tags

renamed DbOptizer into Housekeeper + add Scheduler & triggers
author Alain Mazy <am@osimis.io>
date Mon, 25 Apr 2022 15:30:51 +0200
parents d68b3a2cea17
children d0c34145320c
line wrap: on
line diff
--- a/OrthancServer/CMakeLists.txt	Wed Apr 20 14:36:47 2022 +0200
+++ b/OrthancServer/CMakeLists.txt	Mon Apr 25 15:30:51 2022 +0200
@@ -59,7 +59,7 @@
 SET(BUILD_RECOVER_COMPRESSED_FILE ON CACHE BOOL "Whether to build the companion tool to recover files compressed using Orthanc")
 SET(BUILD_SERVE_FOLDERS ON CACHE BOOL "Whether to build the ServeFolders plugin")
 SET(BUILD_CONNECTIVITY_CHECKS ON CACHE BOOL "Whether to build the ConnectivityChecks plugin")
-SET(BUILD_DB_OPTIMIZER ON CACHE BOOL "Whether to build the DbOptimizer plugin")
+SET(BUILD_HOUSEKEEPER ON CACHE BOOL "Whether to build the Housekeeper plugin")
 SET(ENABLE_PLUGINS ON CACHE BOOL "Enable plugins")
 SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
 
@@ -607,7 +607,7 @@
 
 
 #####################################################################
-## Build the "DbOptimizer" plugin
+## Build the "Housekeeper" plugin
 #####################################################################
 
 if (ENABLE_PLUGINS AND BUILD_DB_OPTIMIZER)
@@ -615,35 +615,35 @@
 execute_process(
   COMMAND 
   ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/../OrthancFramework/Resources/WindowsResources.py
-  ${ORTHANC_VERSION} DbOptimizer DbOptimizer.dll "Sample Orthanc plugin to optimizer/clean the DB/Storage"
+  ${ORTHANC_VERSION} Housekeeper Housekeeper.dll "Sample Orthanc plugin to optimize/clean the DB/Storage"
   ERROR_VARIABLE Failure
-  OUTPUT_FILE ${AUTOGENERATED_DIR}/DbOptimizer.rc
+  OUTPUT_FILE ${AUTOGENERATED_DIR}/Housekeeper.rc
   )
 
 if (Failure)
   message(FATAL_ERROR "Error while computing the version information: ${Failure}")
 endif()
 
-list(APPEND DB_OPTIMIZER_RESOURCES ${AUTOGENERATED_DIR}/DbOptimizer.rc)
+list(APPEND HOUSEKEEPER_RESOURCES ${AUTOGENERATED_DIR}/Housekeeper.rc)
 endif()
 
-add_library(DbOptimizer SHARED 
-${CMAKE_SOURCE_DIR}/Plugins/Samples/DbOptimizer/Plugin.cpp
-${DB_OPTIMIZER_RESOURCES}
+add_library(Housekeeper SHARED 
+${CMAKE_SOURCE_DIR}/Plugins/Samples/Housekeeper/Plugin.cpp
+${HOUSEKEEPER_RESOURCES}
 )
 
-target_link_libraries(DbOptimizer 
+target_link_libraries(Housekeeper 
   ThirdPartyPlugins
   )
 
 set_target_properties(
-  DbOptimizer PROPERTIES 
+  Housekeeper PROPERTIES 
 VERSION ${ORTHANC_VERSION} 
 SOVERSION ${ORTHANC_VERSION}
 )
 
 install(
-TARGETS DbOptimizer
+TARGETS Housekeeper
 RUNTIME DESTINATION lib    # Destination for Windows
 LIBRARY DESTINATION share/orthanc/plugins    # Destination for Linux
 )