diff CMakeLists.txt @ 571:ec2c2411d4db laaw

versioning
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 25 Sep 2013 15:03:24 +0200
parents 86c5bb651bfa
children 8fb9867d8089
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Sep 25 14:01:01 2013 +0200
+++ b/CMakeLists.txt	Wed Sep 25 15:03:24 2013 +0200
@@ -283,6 +283,16 @@
       # Nothing to do if using Visual Studio
     endif()
 
+    if (${CMAKE_SIZEOF_VOID_P} EQUAL 4)
+      set(CMAKE_SHARED_LIBRARY_SUFFIX "_Windows32.dll")
+      list(APPEND ORTHANC_CPP_CLIENT_AUX ${ORTHANC_ROOT}/OrthancCppClient/Package/AUTOGENERATED/Windows32.rc)
+    elseif (${CMAKE_SIZEOF_VOID_P} EQUAL 8)
+      set(CMAKE_SHARED_LIBRARY_SUFFIX "_Windows64.dll")
+      list(APPEND ORTHANC_CPP_CLIENT_AUX ${ORTHANC_ROOT}/OrthancCppClient/Package/AUTOGENERATED/Windows64.rc)
+    else()
+      message(FATAL_ERROR "Support your platform here")
+    endif()    
+
   else()
     set(ORTHANC_CPP_CLIENT_AUX ${OPENSSL_SOURCES})
   endif()
@@ -331,8 +341,8 @@
 
   install(
     TARGETS OrthancClient
-    RUNTIME DESTINATION lib
-    LIBRARY DESTINATION lib
+    RUNTIME DESTINATION lib    # Destination for Windows
+    LIBRARY DESTINATION lib    # Destination for Linux
     )
 
   install(