diff CMakeLists.txt @ 2025:e7e1858d9504

reorganization
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 20 Jun 2016 13:23:42 +0200
parents fefbe71c2272
children 07f2ba3677df
line wrap: on
line diff
--- a/CMakeLists.txt	Sat Jun 18 12:03:32 2016 +0200
+++ b/CMakeLists.txt	Mon Jun 20 13:23:42 2016 +0200
@@ -48,7 +48,7 @@
 SET(USE_SYSTEM_OPENSSL ON CACHE BOOL "Use the system version of OpenSSL")
 SET(USE_SYSTEM_ZLIB ON CACHE BOOL "Use the system version of ZLib")
 SET(USE_SYSTEM_PUGIXML ON CACHE BOOL "Use the system version of Pugixml")
-SET(USE_SYSTEM_LIBP11 ON CACHE BOOL "Use the system version of libp11 (PKCS#11 wrapper library)")
+SET(USE_SYSTEM_LIBP11 OFF CACHE BOOL "Use the system version of libp11 (PKCS#11 wrapper library)")
 
 # Experimental options
 SET(USE_PUGIXML ON CACHE BOOL "Use the Pugixml parser (turn off only for debug)")
@@ -334,8 +334,10 @@
 
 if (ENABLE_PKCS11)
   if (ENABLE_SSL)
+    include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibP11Configuration.cmake)
+
     add_definitions(-DORTHANC_PKCS11_ENABLED=1)
-    include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibP11Configuration.cmake)
+    list(APPEND ORTHANC_CORE_SOURCES Core/Pkcs11.cpp)
   else()
     message(FATAL_ERROR "OpenSSL is required to enable PKCS#11")
   endif()
@@ -442,7 +444,6 @@
   )  
 
 
-
 #####################################################################
 ## Build the Orthanc server
 #####################################################################