diff CMakeLists.txt @ 2404:e6af2c5cd0f1

migration of Google Test into OrthancFramework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 08 Sep 2017 16:48:33 +0200
parents 06536b4f30c0
children be5c0f4155f6
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Sep 08 16:34:47 2017 +0200
+++ b/CMakeLists.txt	Fri Sep 08 16:48:33 2017 +0200
@@ -11,6 +11,9 @@
 
 # Enable all the optional components of the Orthanc framework
 set(ENABLE_CRYPTO_OPTIONS ON)
+set(ENABLE_DCMTK ON)
+set(ENABLE_DCMTK_NETWORKING ON)
+set(ENABLE_GOOGLE_TEST ON)
 set(ENABLE_JPEG ON)
 set(ENABLE_LOCALE ON)
 set(ENABLE_LUA ON)
@@ -19,8 +22,7 @@
 set(ENABLE_SQLITE ON)
 set(ENABLE_WEB_CLIENT ON)
 set(ENABLE_WEB_SERVER ON)
-set(ENABLE_DCMTK ON)
-set(ENABLE_DCMTK_NETWORKING ON)
+
 set(HAS_EMBEDDED_RESOURCES ON)
 
 
@@ -36,12 +38,6 @@
 SET(ENABLE_PLUGINS ON CACHE BOOL "Enable plugins")
 SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
 
-# Advanced parameters to fine-tune linking against system libraries
-SET(USE_GOOGLE_TEST_DEBIAN_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
-SET(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
-
-mark_as_advanced(USE_GOOGLE_TEST_DEBIAN_PACKAGE)
-
 
 #####################################################################
 ## Configuration of the Orthanc framework
@@ -49,7 +45,6 @@
 
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/VisualStudioPrecompiledHeaders.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/OrthancFrameworkConfiguration.cmake)
-include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
 
 include_directories(${ORTHANC_ROOT})
 
@@ -319,8 +314,12 @@
   ${ORTHANC_UNIT_TESTS_SOURCES}
   )
 
-target_link_libraries(UnitTests ServerLibrary CoreLibrary ${DCMTK_LIBRARIES})
-
+target_link_libraries(UnitTests
+  ServerLibrary
+  CoreLibrary
+  ${DCMTK_LIBRARIES}
+  ${GOOGLE_TEST_LIBRARIES}
+  )
 
 
 #####################################################################