diff CMakeLists.txt @ 4031:e3b3af80732d

ServerResources, and moving EmbeddedResourceHttpHandler from Core to OrthancServer
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 09 Jun 2020 21:31:13 +0200
parents 100fbe970762
children 058b5ade8acd
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Jun 09 20:50:20 2020 +0200
+++ b/CMakeLists.txt	Tue Jun 09 21:31:13 2020 +0200
@@ -65,14 +65,15 @@
   OrthancServer/Database/SQLiteDatabaseWrapper.cpp
   OrthancServer/DicomInstanceOrigin.cpp
   OrthancServer/DicomInstanceToStore.cpp
+  OrthancServer/EmbeddedResourceHttpHandler.cpp
   OrthancServer/ExportedResource.cpp
   OrthancServer/LuaScripting.cpp
   OrthancServer/OrthancConfiguration.cpp
   OrthancServer/OrthancFindRequestHandler.cpp
+  OrthancServer/OrthancGetRequestHandler.cpp
   OrthancServer/OrthancHttpHandler.cpp
   OrthancServer/OrthancInitialization.cpp
   OrthancServer/OrthancMoveRequestHandler.cpp
-  OrthancServer/OrthancGetRequestHandler.cpp
   OrthancServer/OrthancRestApi/OrthancRestAnonymizeModify.cpp
   OrthancServer/OrthancRestApi/OrthancRestApi.cpp
   OrthancServer/OrthancRestApi/OrthancRestArchive.cpp
@@ -165,6 +166,7 @@
     ${ORTHANC_DICOM_SOURCES_INTERNAL}
     ${ORTHANC_SERVER_SOURCES}
     ${ORTHANC_UNIT_TESTS_SOURCES}
+    ${ORTHANC_ROOT}/Core/HttpServer/EmbeddedResourceHttpHandler.cpp
     Plugins/Samples/ServeFolders/Plugin.cpp
     Plugins/Samples/ModalityWorklists/Plugin.cpp
     OrthancServer/main.cpp
@@ -196,29 +198,26 @@
 if (STANDALONE_BUILD)
   # We embed all the resources in the binaries for standalone builds
   add_definitions(
-    -DORTHANC_HAS_EMBEDDED_RESOURCES=1
     -DORTHANC_STANDALONE=1
     )
-  EmbedResources(
-    --target=OrthancEmbeddedResources
-    ${ORTHANC_EMBEDDED_FILES}
+
+  list(APPEND ORTHANC_EMBEDDED_FILES
     ORTHANC_EXPLORER ${CMAKE_CURRENT_SOURCE_DIR}/OrthancExplorer
-    ${DCMTK_DICTIONARIES}
-    ${LIBICU_RESOURCES}
     )
 else()
   add_definitions(
-    -DORTHANC_HAS_EMBEDDED_RESOURCES=1
     -DORTHANC_PATH=\"${CMAKE_SOURCE_DIR}\"
     -DORTHANC_STANDALONE=0
     )
-  EmbedResources(
-    --target=OrthancEmbeddedResources
-    ${ORTHANC_EMBEDDED_FILES}
-    ${LIBICU_RESOURCES}
-    )
 endif()
 
+EmbedResources(
+  --namespace=Orthanc.ServerResources
+  --target=ServerResources
+  ${ORTHANC_EMBEDDED_FILES}
+  )
+
+
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
   execute_process(
     COMMAND