diff CMakeLists.txt @ 4063:e00f3d089991 framework

shared library of orthanc framework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 11 Jun 2020 16:40:34 +0200
parents 149172a06b4d
children
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jun 11 14:38:31 2020 +0200
+++ b/CMakeLists.txt	Thu Jun 11 16:40:34 2020 +0200
@@ -248,6 +248,13 @@
 ## Configuration of the C/C++ macros
 #####################################################################
 
+if (STATIC_BUILD)
+  add_definitions(-DORTHANC_STATIC=1)
+else()
+  add_definitions(-DORTHANC_STATIC=0)
+endif()
+
+
 if (ENABLE_PLUGINS)
   add_definitions(-DORTHANC_ENABLE_PLUGINS=1)
 else()