diff CMakeLists.txt @ 839:dfb13218f8ca jpeg

jpeg
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 03 Jun 2014 17:55:44 +0200
parents 22964c7ff1c3
children ffa8c7dcd87c
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Jun 02 13:01:02 2014 +0200
+++ b/CMakeLists.txt	Tue Jun 03 17:55:44 2014 +0200
@@ -18,6 +18,7 @@
 SET(DCMTK_DICTIONARY_DIR "" CACHE PATH "Directory containing the DCMTK dictionaries \"dicom.dic\" and \"private.dic\" (only when using system version of DCMTK)") 
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
 SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
+SET(ENABLE_JPEG_LOSSLESS CACHE BOOL "Enable JPEG Lossless decompression")
 
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
@@ -164,6 +165,13 @@
   )
 
 
+if (ENABLE_JPEG_LOSSLESS)
+  list(APPEND ORTHANC_UNIT_TESTS_SOURCES
+    UnitTestsSources/JpegLossless.cpp
+    )
+endif()
+
+
 
 #####################################################################
 ## Inclusion of third-party dependencies
@@ -201,6 +209,13 @@
 endif()
 
 
+if (ENABLE_JPEG_LOSSLESS)
+  add_definitions(-DORTHANC_JPEG_LOSSLESS_ENABLED=1)
+else()
+  add_definitions(-DORTHANC_JPEG_LOSSLESS_ENABLED=0)
+endif()
+
+
 
 #####################################################################
 ## Autogeneration of files