diff Resources/Testing/Issue32/Cpp/CMakeLists.txt @ 3122:df4f977c2f88

trying to reproduce isse 32 in C++
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 15 Jan 2019 13:06:03 +0100
parents
children f6cb16413325
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Resources/Testing/Issue32/Cpp/CMakeLists.txt	Tue Jan 15 13:06:03 2019 +0100
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Orthanc)
+
+set(ORTHANC_ROOT ${CMAKE_SOURCE_DIR}/../../../../Resources/CMake)
+
+include(${ORTHANC_ROOT}/OrthancFrameworkParameters.cmake)
+set(ENABLE_WEB_CLIENT ON)
+include(${ORTHANC_ROOT}/OrthancFrameworkConfiguration.cmake)
+
+add_definitions(
+  -DORTHANC_ENABLE_LOGGING_PLUGIN=OFF
+  )
+
+include_directories(${ORTHANC_ROOT})
+
+add_executable(Sample
+  main.cpp
+  ${ORTHANC_CORE_SOURCES}
+  )
\ No newline at end of file