diff CMakeLists.txt @ 3050:d8a91acb7424 db-changes

working on a database compatibility layer
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 20 Dec 2018 16:42:35 +0100
parents 1c095185074c
children c7db469bbe8e
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Dec 20 16:18:38 2018 +0100
+++ b/CMakeLists.txt	Thu Dec 20 16:42:35 2018 +0100
@@ -53,7 +53,6 @@
 #####################################################################
 
 set(ORTHANC_SERVER_SOURCES
-  OrthancServer/SQLiteDatabaseWrapper.cpp
   OrthancServer/DicomInstanceOrigin.cpp
   OrthancServer/DicomInstanceToStore.cpp
   OrthancServer/ExportedResource.cpp
@@ -71,6 +70,8 @@
   OrthancServer/OrthancRestApi/OrthancRestResources.cpp
   OrthancServer/OrthancRestApi/OrthancRestSystem.cpp
   OrthancServer/QueryRetrieveHandler.cpp
+  OrthancServer/SQLiteDatabaseWrapper.cpp
+  OrthancServer/Search/Compatibility/SetOfResources.cpp
   OrthancServer/Search/DatabaseConstraint.cpp
   OrthancServer/Search/DatabaseLookup.cpp
   OrthancServer/Search/DicomTagConstraint.cpp
@@ -132,7 +133,6 @@
     Plugins/Engine/PluginsErrorDictionary.cpp
     Plugins/Engine/PluginsJob.cpp
     Plugins/Engine/PluginsManager.cpp
-    Plugins/Engine/SetOfResources.cpp
     )
 
   list(APPEND ORTHANC_UNIT_TESTS_SOURCES