diff CMakeLists.txt @ 1407:d371a66972a4

OrthancPluginGetExpectedDatabaseVersion
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 03 Jun 2015 10:19:13 +0200
parents 1c8df4424437
children 823e82ee43bb
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Jun 02 17:48:13 2015 +0200
+++ b/CMakeLists.txt	Wed Jun 03 10:19:13 2015 +0200
@@ -5,6 +5,14 @@
 # Version of the build, should always be "mainline" except in release branches
 set(ORTHANC_VERSION "mainline")
 
+# Version of the database schema. History:
+#   * Orthanc 0.1.0 -> Orthanc 0.3.0 = no versioning
+#   * Orthanc 0.3.1                  = version 2
+#   * Orthanc 0.4.0 -> Orthanc 0.7.2 = version 3
+#   * Orthanc 0.7.3 -> Orthanc 0.8.4 = version 4
+#   * Orthanc 0.8.5 -> mainline      = version 5
+set(ORTHANC_DATABASE_VERSION 5)
+
 
 #####################################################################
 ## CMake parameters tunable at the command line
@@ -308,6 +316,7 @@
 
 add_definitions(
   -DORTHANC_VERSION="${ORTHANC_VERSION}"
+  -DORTHANC_DATABASE_VERSION=${ORTHANC_DATABASE_VERSION}
   )
 
 list(LENGTH OPENSSL_SOURCES OPENSSL_SOURCES_LENGTH)