diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 4107:d36b38da5947

uninstall target for the orthanc framework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 06 Jul 2020 20:57:49 +0200
parents c5efe8897da8
children 9286649df279
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Mon Jul 06 19:24:22 2020 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Mon Jul 06 20:57:49 2020 +0200
@@ -488,3 +488,18 @@
 
   add_dependencies(UnitTests OrthancFramework)
 endif()
+
+
+
+#####################################################################
+## Prepare the "uninstall" target
+## http://www.cmake.org/Wiki/CMake_FAQ#Can_I_do_.22make_uninstall.22_with_CMake.3F
+#####################################################################
+
+configure_file(
+  "${CMAKE_SOURCE_DIR}/../Resources/CMake/Uninstall.cmake.in"
+  "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+  IMMEDIATE @ONLY)
+
+add_custom_target(uninstall
+  COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)