diff OrthancServer/Plugins/Samples/ServeFolders/CMakeLists.txt @ 4044:d25f4c0fa160 framework

splitting code into OrthancFramework and OrthancServer
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 10 Jun 2020 20:30:34 +0200
parents Plugins/Samples/ServeFolders/CMakeLists.txt@fead5549aaa7
children cd363608551a
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/OrthancServer/Plugins/Samples/ServeFolders/CMakeLists.txt	Wed Jun 10 20:30:34 2020 +0200
@@ -0,0 +1,37 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(ServeFolders)
+
+SET(SERVE_FOLDERS_VERSION "0.0" CACHE STRING "Version of the plugin")
+SET(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
+SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
+
+SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
+SET(USE_SYSTEM_BOOST ON CACHE BOOL "Use the system version of boost")
+
+set(SAMPLES_ROOT ${CMAKE_SOURCE_DIR}/..)
+include(${CMAKE_SOURCE_DIR}/../Common/OrthancPlugins.cmake)
+include(${ORTHANC_ROOT}/Resources/CMake/JsonCppConfiguration.cmake)
+include(${ORTHANC_ROOT}/Resources/CMake/BoostConfiguration.cmake)
+
+add_library(ServeFolders SHARED 
+  Plugin.cpp
+  ${CMAKE_SOURCE_DIR}/../Common/OrthancPluginCppWrapper.cpp
+  ${JSONCPP_SOURCES}
+  ${BOOST_SOURCES}
+  )
+
+add_definitions(-DHAS_ORTHANC_EXCEPTION=0)
+
+message("Setting the version of the plugin to ${SERVE_FOLDERS_VERSION}")
+add_definitions(-DSERVE_FOLDERS_VERSION="${SERVE_FOLDERS_VERSION}")
+
+set_target_properties(ServeFolders PROPERTIES 
+  VERSION ${SERVE_FOLDERS_VERSION} 
+  SOVERSION ${SERVE_FOLDERS_VERSION})
+
+install(
+  TARGETS ServeFolders
+  RUNTIME DESTINATION lib    # Destination for Windows
+  LIBRARY DESTINATION share/orthanc/plugins    # Destination for Linux
+  )