diff OrthancServer/Resources/Graveyard/DatabasePluginSample/CMakeLists.txt @ 4050:cd363608551a framework

fix paths
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 11 Jun 2020 11:44:48 +0200
parents d25f4c0fa160
children
line wrap: on
line diff
--- a/OrthancServer/Resources/Graveyard/DatabasePluginSample/CMakeLists.txt	Thu Jun 11 10:05:26 2020 +0200
+++ b/OrthancServer/Resources/Graveyard/DatabasePluginSample/CMakeLists.txt	Thu Jun 11 11:44:48 2020 +0200
@@ -13,54 +13,49 @@
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
 SET(USE_SYSTEM_SQLITE ON CACHE BOOL "Use the system version of SQLite")
 
-set(SAMPLES_ROOT ${CMAKE_SOURCE_DIR}/..)
-include(${SAMPLES_ROOT}/Common/OrthancPlugins.cmake)
+include(${CMAKE_SOURCE_DIR}/../../../Plugins/Samples/Common/OrthancPlugins.cmake)
 
-include(${ORTHANC_ROOT}/Resources/CMake/BoostConfiguration.cmake)
-include(${ORTHANC_ROOT}/Resources/CMake/JsonCppConfiguration.cmake)
-include(${ORTHANC_ROOT}/Resources/CMake/SQLiteConfiguration.cmake)
+include(${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Resources/CMake/OrthancFrameworkParameters.cmake)
+set(ENABLE_SQLITE ON)
+include(${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Resources/CMake/OrthancFrameworkConfiguration.cmake)
 
 EmbedResources(
   --system-exception  # Use "std::runtime_error" instead of "OrthancException" for embedded resources
-  PREPARE_DATABASE  ${ORTHANC_ROOT}/OrthancServer/PrepareDatabase.sql
+  PREPARE_DATABASE  ${CMAKE_SOURCE_DIR}/../../../Sources/Database/PrepareDatabase.sql
   )
 
 message("Setting the version of the plugin to ${SAMPLE_DATABASE_VERSION}")
 
 add_definitions(
   -DORTHANC_SQLITE_STANDALONE=1
-  -DORTHANC_ENABLE_BASE64=0
-  -DORTHANC_ENABLE_LOGGING=0
-  -DORTHANC_ENABLE_MD5=0
   -DORTHANC_ENABLE_PLUGINS=1
-  -DORTHANC_ENABLE_PUGIXML=0
   -DORTHANC_SANDBOXED=0
   -DSAMPLE_DATABASE_VERSION="${SAMPLE_DATABASE_VERSION}"
   )
 
 add_library(SampleDatabase SHARED 
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/DicomFormat/DicomArray.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/DicomFormat/DicomMap.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/DicomFormat/DicomTag.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/DicomFormat/DicomValue.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/Enumerations.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/Connection.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/FunctionContext.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/Statement.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/StatementId.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/StatementReference.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/SQLite/Transaction.cpp
+  ${CMAKE_SOURCE_DIR}/../../../../OrthancFramework/Sources/Toolbox.cpp
+  ${CMAKE_SOURCE_DIR}/../../../Plugins/Engine/PluginsEnumerations.cpp
+
+  Database.cpp
+  Plugin.cpp
+  DatabaseWrapperBase.cpp
+  
   ${BOOST_SOURCES}
   ${JSONCPP_SOURCES}
   ${SQLITE_SOURCES}
   ${AUTOGENERATED_SOURCES}
-
-  ${ORTHANC_ROOT}/Core/DicomFormat/DicomArray.cpp
-  ${ORTHANC_ROOT}/Core/DicomFormat/DicomMap.cpp
-  ${ORTHANC_ROOT}/Core/DicomFormat/DicomTag.cpp
-  ${ORTHANC_ROOT}/Core/DicomFormat/DicomValue.cpp
-  ${ORTHANC_ROOT}/Core/Enumerations.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/Connection.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/FunctionContext.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/Statement.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/StatementId.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/StatementReference.cpp
-  ${ORTHANC_ROOT}/Core/SQLite/Transaction.cpp
-  ${ORTHANC_ROOT}/Core/Toolbox.cpp
-  ${ORTHANC_ROOT}/OrthancServer/DatabaseWrapperBase.cpp
-  ${ORTHANC_ROOT}/Plugins/Engine/PluginsEnumerations.cpp
-
-  Database.cpp
-  Plugin.cpp
   )
 
 set_target_properties(SampleDatabase PROPERTIES