diff CMakeLists.txt @ 1488:c8763b603b0e

flag for plugins
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 04 Aug 2015 10:54:13 +0200
parents 23083810d543
children 596927722403
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Aug 04 10:45:58 2015 +0200
+++ b/CMakeLists.txt	Tue Aug 04 10:54:13 2015 +0200
@@ -356,6 +356,7 @@
 add_definitions(
   -DORTHANC_VERSION="${ORTHANC_VERSION}"
   -DORTHANC_DATABASE_VERSION=${ORTHANC_DATABASE_VERSION}
+  -DORTHANC_ENABLE_LOGGING=1
   )
 
 list(LENGTH OPENSSL_SOURCES OPENSSL_SOURCES_LENGTH)
@@ -426,7 +427,10 @@
   add_definitions(-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=0)
 endif()
 
-add_definitions(-DORTHANC_BUILD_UNIT_TESTS=1)
+add_definitions(
+  -DORTHANC_BUILD_UNIT_TESTS=1
+  )
+
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
 add_executable(UnitTests
   ${GTEST_SOURCES}