diff CMakeLists.txt @ 2175:bed8e7ad8bab

ENABLE_PROFILING cmake option
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 24 Nov 2016 12:58:43 +0100
parents f75611abd407
children fead5549aaa7
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Nov 23 16:12:04 2016 +0100
+++ b/CMakeLists.txt	Thu Nov 24 12:58:43 2016 +0100
@@ -33,6 +33,7 @@
 SET(BUILD_MODALITY_WORKLISTS ON CACHE BOOL "Whether to build the sample plugin to serve modality worklists")
 SET(BUILD_RECOVER_COMPRESSED_FILE ON CACHE BOOL "Whether to build the companion tool to recover files compressed using Orthanc")
 SET(ENABLE_PKCS11 OFF CACHE BOOL "Enable PKCS#11 for HTTPS client authentication using hardware security modules and smart cards")
+SET(ENABLE_PROFILING OFF CACHE BOOL "Whether to enable the generation of profiling information with gprof")
 
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")