diff CMakeLists.txt @ 626:b8322fe3bdba

possibility to disable the use of system dcmtk or boost
author jodogne
date Tue, 29 Oct 2013 09:00:44 +0100
parents 70d0f27e5bd3
children e207b33216db
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Oct 25 12:43:02 2013 +0200
+++ b/CMakeLists.txt	Tue Oct 29 09:00:44 2013 +0100
@@ -25,6 +25,8 @@
 SET(USE_DYNAMIC_SQLITE ON CACHE BOOL "Use the dynamic version of SQLite")
 SET(USE_DYNAMIC_MONGOOSE OFF CACHE BOOL "Use the dynamic version of Mongoose")
 SET(USE_DYNAMIC_LUA OFF CACHE BOOL "Use the dynamic version of Lua")
+SET(USE_SYSTEM_DCMTK ON CACHE BOOL "Use the system version of DCMTK")
+SET(USE_SYSTEM_BOOST ON CACHE BOOL "Use the system version of Boost")
 SET(DEBIAN_USE_GTEST_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
 
 mark_as_advanced(USE_DYNAMIC_JSONCPP)