diff Plugins/Samples/ServeFolders/CMakeLists.txt @ 1391:b3119c32c920

version in ServerFolders plugin
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 29 May 2015 17:32:00 +0200
parents 92da9e1c2daa
children 56f613d1df29
line wrap: on
line diff
--- a/Plugins/Samples/ServeFolders/CMakeLists.txt	Fri May 29 17:24:01 2015 +0200
+++ b/Plugins/Samples/ServeFolders/CMakeLists.txt	Fri May 29 17:32:00 2015 +0200
@@ -2,6 +2,7 @@
 
 project(ServeFolders)
 
+SET(SERVE_FOLDERS_VERSION "0.0" CACHE STRING "Version of the plugin")
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
 
@@ -17,3 +18,17 @@
   Plugin.cpp
   ${THIRD_PARTY_SOURCES}
   )
+
+
+message("Setting the version of the plugin to ${SERVE_FOLDERS_VERSION}")
+add_definitions(-DSERVE_FOLDERS_VERSION="${SERVE_FOLDERS_VERSION}")
+
+set_target_properties(ServeFolders PROPERTIES 
+  VERSION ${SERVE_FOLDERS_VERSION} 
+  SOVERSION ${SERVE_FOLDERS_VERSION})
+
+install(
+  TARGETS ServeFolders
+  RUNTIME DESTINATION lib    # Destination for Windows
+  LIBRARY DESTINATION share/orthanc/plugins    # Destination for Linux
+  )