diff CMakeLists.txt @ 1024:a93867a94011 templating

smoother integration of plustache
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 10 Jul 2014 11:53:23 +0200
parents 226cfef3822e
children 7f748bac15e5
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jul 10 11:42:32 2014 +0200
+++ b/CMakeLists.txt	Thu Jul 10 11:53:23 2014 +0200
@@ -21,6 +21,9 @@
 SET(ENABLE_JPEG ON CACHE BOOL "Enable JPEG decompression")
 SET(ENABLE_JPEG_LOSSLESS ON CACHE BOOL "Enable JPEG-LS (Lossless) decompression")
 
+# Experimental options
+SET(USE_PLUSTACHE OFF CACHE BOOL "Use the Plustache templating engine (experimental)")
+
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
 SET(USE_SYSTEM_GOOGLE_LOG ON CACHE BOOL "Use the system version of Google Log")
@@ -34,6 +37,7 @@
 SET(USE_SYSTEM_CURL ON CACHE BOOL "Use the system version of LibCurl")
 SET(USE_SYSTEM_OPENSSL ON CACHE BOOL "Use the system version of OpenSSL")
 SET(USE_SYSTEM_ZLIB ON CACHE BOOL "Use the system version of ZLib")
+SET(USE_SYSTEM_PLUSTACHE OFF CACHE BOOL "Use the system version of Plustache (experimental)")
 
 # Distribution-specific settings
 SET(USE_GTEST_DEBIAN_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
@@ -187,7 +191,7 @@
   UnitTestsSources/ImageProcessingTests.cpp
   UnitTestsSources/JpegLosslessTests.cpp
   UnitTestsSources/PluginsTests.cpp
-  UnitTestsSources/Plustache.cpp
+  UnitTestsSources/PlustacheTests.cpp
   )