diff CMakeLists.txt @ 1455:a68545767975

Initialize() and Finalize() events in Lua
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 02 Jul 2015 15:17:19 +0200
parents b2b09a3dbd8e
children d659b6a4e736
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jul 02 12:30:55 2015 +0200
+++ b/CMakeLists.txt	Thu Jul 02 15:17:19 2015 +0200
@@ -27,6 +27,7 @@
 SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
 SET(ENABLE_JPEG ON CACHE BOOL "Enable JPEG decompression")
 SET(ENABLE_JPEG_LOSSLESS ON CACHE BOOL "Enable JPEG-LS (Lossless) decompression")
+SET(ENABLE_PLUGINS ON CACHE BOOL "Enable plugins")
 
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
@@ -54,6 +55,7 @@
 mark_as_advanced(USE_GTEST_DEBIAN_SOURCE_PACKAGE)
 mark_as_advanced(SYSTEM_MONGOOSE_USE_CALLBACKS)
 mark_as_advanced(USE_BOOST_ICONV)
+mark_as_advanced(USE_PUGIXML)
 
 # Path to the root folder of the Orthanc distribution
 set(ORTHANC_ROOT ${CMAKE_SOURCE_DIR})
@@ -261,6 +263,13 @@
 endif()
 
 
+if (ENABLE_PLUGINS)
+  add_definitions(-DORTHANC_PLUGINS_ENABLED=1)
+else()
+  add_definitions(-DORTHANC_PLUGINS_ENABLED=0)
+endif()
+
+
 
 #####################################################################
 ## Autogeneration of files