diff CMakeLists.txt @ 850:9ee2e7a5efaf jpeg

support of JPEG images
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 06 Jun 2014 09:42:10 +0200
parents 48016722c770
children 839be3022203
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Jun 05 21:32:55 2014 +0200
+++ b/CMakeLists.txt	Fri Jun 06 09:42:10 2014 +0200
@@ -18,7 +18,8 @@
 SET(DCMTK_DICTIONARY_DIR "" CACHE PATH "Directory containing the DCMTK dictionaries \"dicom.dic\" and \"private.dic\" (only when using system version of DCMTK)") 
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
 SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
-SET(ENABLE_JPEG_LOSSLESS CACHE BOOL "Enable JPEG Lossless decompression")
+SET(ENABLE_JPEG ON CACHE BOOL "Enable JPEG decompression")
+SET(ENABLE_JPEG_LOSSLESS ON CACHE BOOL "Enable JPEG-LS (Lossless) decompression")
 
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
@@ -204,6 +205,13 @@
 endif()
 
 
+if (ENABLE_JPEG)
+  add_definitions(-DORTHANC_JPEG_ENABLED=1)
+else()
+  add_definitions(-DORTHANC_JPEG_ENABLED=0)
+endif()
+
+
 if (ENABLE_JPEG_LOSSLESS)
   add_definitions(-DORTHANC_JPEG_LOSSLESS_ENABLED=1)
 else()