diff Plugins/Samples/ModalityWorklists/CMakeLists.txt @ 1808:9c2ffc4e938b worklists

configuration of the sample modality worklists plugin
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 23 Nov 2015 16:58:55 +0100
parents 138664eb59de
children 395522e46b2b
line wrap: on
line diff
--- a/Plugins/Samples/ModalityWorklists/CMakeLists.txt	Mon Nov 23 15:26:42 2015 +0100
+++ b/Plugins/Samples/ModalityWorklists/CMakeLists.txt	Mon Nov 23 16:58:55 2015 +0100
@@ -1,8 +1,8 @@
 cmake_minimum_required(VERSION 2.8)
 
-project(SampleModalityWorklists)
+project(ModalityWorklists)
 
-SET(SAMPLE_MODALITY_WORKLISTS_VERSION "0.0" CACHE STRING "Version of the plugin")
+SET(MODALITY_WORKLISTS_VERSION "0.0" CACHE STRING "Version of the plugin")
 SET(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
 
@@ -10,28 +10,27 @@
 SET(USE_SYSTEM_BOOST ON CACHE BOOL "Use the system version of boost")
 
 set(SAMPLES_ROOT ${CMAKE_SOURCE_DIR}/..)
-include(${CMAKE_SOURCE_DIR}/../Common/OrthancPlugins.cmake)
+include(${SAMPLES_ROOT}/Common/OrthancPlugins.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/JsonCppConfiguration.cmake)
 include(${ORTHANC_ROOT}/Resources/CMake/BoostConfiguration.cmake)
 
-add_library(SampleModalityWorklists SHARED 
+add_library(ModalityWorklists SHARED 
   Plugin.cpp
   ${JSONCPP_SOURCES}
   ${BOOST_SOURCES}
   )
 
-message("Setting the version of the plugin to ${SAMPLE_MODALITY_WORKLISTS_VERSION}")
+message("Setting the version of the plugin to ${MODALITY_WORKLISTS_VERSION}")
 add_definitions(
-  -DSAMPLE_MODALITY_WORKLISTS_VERSION="${SAMPLE_MODALITY_WORKLISTS_VERSION}"
-  -DDEFAULT_WORKLISTS_FOLDER="${CMAKE_SOURCE_DIR}/WorklistsDatabase"
+  -DMODALITY_WORKLISTS_VERSION="${MODALITY_WORKLISTS_VERSION}"
   )
 
-set_target_properties(SampleModalityWorklists PROPERTIES 
-  VERSION ${SAMPLE_MODALITY_WORKLISTS_VERSION} 
-  SOVERSION ${SAMPLE_MODALITY_WORKLISTS_VERSION})
+set_target_properties(ModalityWorklists PROPERTIES 
+  VERSION ${MODALITY_WORKLISTS_VERSION} 
+  SOVERSION ${MODALITY_WORKLISTS_VERSION})
 
 install(
-  TARGETS SampleModalityWorklists
+  TARGETS ModalityWorklists
   RUNTIME DESTINATION lib    # Destination for Windows
   LIBRARY DESTINATION share/orthanc/plugins    # Destination for Linux
   )