diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 4097:99e2054d1e8d

fix unit tests for orthanc framework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 01 Jul 2020 11:15:29 +0200
parents 1c89208fbba9
children 90eaf36e6adf
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Wed Jul 01 08:42:21 2020 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Wed Jul 01 11:15:29 2020 +0200
@@ -462,7 +462,11 @@
   if (CMAKE_TOOLCHAIN_FILE)
     # Take absolute path to the toolchain
     get_filename_component(TMP ${CMAKE_TOOLCHAIN_FILE} REALPATH BASE ${CMAKE_SOURCE_DIR}/..)
-    list(APPEND Flags -DCMAKE_TOOLCHAIN_FILE=${TMP})
+    list(APPEND Flags
+      -DCMAKE_TOOLCHAIN_FILE=${TMP}
+      -DLSB_CC=${LSB_CC}
+      -DLSB_CXX=${LSB_CXX}
+      )
   endif()
 
   # Build the unit tests, linking them against the just-created