diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 4117:9286649df279

use of C++11 in the unit tests of the shared library
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 07 Jul 2020 14:23:23 +0200
parents d36b38da5947
children a0c30785b7d7
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Tue Jul 07 13:12:23 2020 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Tue Jul 07 14:23:23 2020 +0200
@@ -466,6 +466,10 @@
       )
   endif()
 
+  if (JSONCPP_CXX11)
+    list(APPEND Flags -DUSE_CXX11=1)
+  endif()
+  
   # Build the unit tests, linking them against the just-created
   # "OrthancFramework" library
   externalproject_add(UnitTests