diff Plugins/Samples/ConnectivityChecks/CMakeLists.txt @ 3622:8afc14fab01f

New sample plugin: ConnectivityChecks
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 24 Jan 2020 17:06:23 +0100
parents
children a6bfa09df8b3
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Plugins/Samples/ConnectivityChecks/CMakeLists.txt	Fri Jan 24 17:06:23 2020 +0100
@@ -0,0 +1,60 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(ConnectivityChecks)
+
+SET(PLUGIN_NAME "connectivity-checks" CACHE STRING "Name of the plugin")
+SET(PLUGIN_VERSION "mainline" CACHE STRING "Version of the plugin")
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../../Resources/CMake/OrthancFrameworkParameters.cmake)
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../../Resources/CMake/OrthancFrameworkConfiguration.cmake)
+
+include(JavaScriptLibraries.cmake)
+
+if (${CMAKE_SYSTEM_NAME} STREQUAL "Windows")
+  execute_process(
+    COMMAND 
+    ${PYTHON_EXECUTABLE} ${ORTHANC_ROOT}/Resources/WindowsResources.py
+    ${PLUGIN_VERSION} ConnectivityChecks ConnectivityChecks.dll "Orthanc plugin to serve additional folders"
+    ERROR_VARIABLE Failure
+    OUTPUT_FILE ${AUTOGENERATED_DIR}/ConnectivityChecks.rc
+    )
+
+  if (Failure)
+    message(FATAL_ERROR "Error while computing the version information: ${Failure}")
+  endif()
+
+  list(APPEND ADDITIONAL_RESOURCES ${AUTOGENERATED_DIR}/ConnectivityChecks.rc)
+endif()  
+
+EmbedResources(
+  WEB_RESOURCES  ${CMAKE_CURRENT_SOURCE_DIR}/WebResources
+  LIBRARIES      ${JAVASCRIPT_LIBS_DIR}
+  )
+
+add_definitions(
+  -DHAS_ORTHANC_EXCEPTION=1
+  -DORTHANC_ENABLE_LOGGING_PLUGIN=1
+  -DORTHANC_PLUGIN_NAME="${PLUGIN_NAME}"
+  -DORTHANC_PLUGIN_VERSION="${PLUGIN_VERSION}"
+  )
+
+include_directories(
+  ${ORTHANC_ROOT}/Plugins/Include/
+  )
+
+add_library(OrthancChecks SHARED
+  ${ADDITIONAL_RESOURCES}
+  ${AUTOGENERATED_SOURCES}
+  ${ORTHANC_CORE_SOURCES_DEPENDENCIES}
+  ${ORTHANC_ROOT}/Core/Enumerations.cpp
+  ${ORTHANC_ROOT}/Core/Logging.cpp
+  ${ORTHANC_ROOT}/Core/SystemToolbox.cpp
+  ${ORTHANC_ROOT}/Core/Toolbox.cpp
+  Plugin.cpp
+  )
+
+set_target_properties(
+  OrthancChecks PROPERTIES 
+  VERSION ${PLUGIN_VERSION} 
+  SOVERSION ${PLUGIN_VERSION}
+  )