diff CMakeLists.txt @ 2338:86a99fd1bbfb

switch to just-released dcmtk 3.6.2
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 17 Jul 2017 18:49:45 +0200
parents 423d3b692bb9
children 6e26d363dc53
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Jul 17 18:47:46 2017 +0200
+++ b/CMakeLists.txt	Mon Jul 17 18:49:45 2017 +0200
@@ -53,8 +53,7 @@
 
 # Advanced parameters
 SET(USE_PUGIXML ON CACHE BOOL "Use the Pugixml parser (turn off only for debug)")
-SET(USE_DCMTK_361 OFF CACHE BOOL "Use forthcoming DCMTK version 3.6.1 in static builds (instead of 3.6.0)")
-SET(USE_DCMTK_361_PRIVATE_DIC ON CACHE BOOL "Use the dictionary of private tags from DCMTK 3.6.1 in static builds (which is more up-to-date)")
+SET(USE_DCMTK_360 OFF CACHE BOOL "Use older DCMTK version 3.6.0 in static builds (instead of default 3.6.2)")
 
 # Distribution-specific settings
 SET(USE_GTEST_DEBIAN_SOURCE_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
@@ -268,7 +267,7 @@
 
 if (CMAKE_COMPILER_IS_GNUCXX
     AND NOT CMAKE_CROSSCOMPILING 
-    AND NOT USE_DCMTK_361)
+    AND USE_DCMTK_360)
   # Add the "-pedantic" flag only on the Orthanc sources, and only if
   # using DCMTK 3.6.0
   set_source_files_properties(${ORTHANC_ALL_SOURCES}