diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 5073:859f3668c181

replaced macro "#warning" by "#pragma message" for Visual Studio
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 16 Aug 2022 11:06:25 +0200
parents 2e3006382c22
children fa3699115b48
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Mon Aug 15 22:13:39 2022 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Tue Aug 16 11:06:25 2022 +0200
@@ -508,6 +508,14 @@
       )
   endif()
 
+  if (STATIC_BUILD OR NOT USE_SYSTEM_DCMTK)
+    list(APPEND Flags
+      # This is necessary to compile "dcmtk/dcmdata/dctagkey.h" because of
+      # macro "DCMTK_DIAGNOSTIC_IGNORE_ATTRIBUTE_REDECLARATION"
+      -DCMAKE_CXX_STANDARD_INCLUDE_DIRECTORIES=${DCMTK_SOURCES_DIR}/ofstd/include
+      )
+  endif()
+
   # Build the unit tests, linking them against the just-created
   # "OrthancFramework" library
   externalproject_add(UnitTests