diff OrthancServer/CMakeLists.txt @ 5573:823aae1ea72a

removed dependency of HouseKeeper upon Orthanc::Logging
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 26 Apr 2024 16:01:26 +0200
parents 0b18690c1935
children 9e74e761b108 f7adfb22e20e
line wrap: on
line diff
--- a/OrthancServer/CMakeLists.txt	Fri Apr 26 15:50:01 2024 +0200
+++ b/OrthancServer/CMakeLists.txt	Fri Apr 26 16:01:26 2024 +0200
@@ -496,10 +496,6 @@
     
     ${CMAKE_SOURCE_DIR}/../OrthancFramework/Resources/ThirdParty/base64/base64.cpp
     ${CMAKE_SOURCE_DIR}/../OrthancFramework/Resources/ThirdParty/md5/md5.c
-
-    # the orthanc framework sources
-    ${ORTHANC_CORE_SOURCES}
-
     Plugins/Samples/Common/OrthancPluginCppWrapper.cpp
     )
 
@@ -524,8 +520,6 @@
 
   DefineSourceBasenameForTarget(PluginsDependencies)
 
-  target_include_directories(PluginsDependencies PUBLIC ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources)
-
   # Add the "-fPIC" option as this static library must be embedded
   # inside shared libraries (important on UNIX)
   set_target_properties(