diff Resources/Samples/OrthancCppClientStandalone/Basic/CMakeLists.txt @ 531:7f9467b5f33b laaw

samples
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 19 Jul 2013 17:16:15 +0200
parents
children a0001c222b32
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Resources/Samples/OrthancCppClientStandalone/Basic/CMakeLists.txt	Fri Jul 19 17:16:15 2013 +0200
@@ -0,0 +1,13 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Basic)
+
+add_executable(Test main.cpp)
+
+if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+  # Linking with "pthread" is necessary, otherwise the software crashes
+  # http://sourceware.org/bugzilla/show_bug.cgi?id=10652#c17
+  target_link_libraries(Test pthread dl)
+else()
+  set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -static-libgcc -static-libstdc++")
+endif()