diff OrthancFramework/UnitTestsSources/CMakeLists.txt @ 4309:73de065622ec

missing cmake parameters if building unit tests of framework
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sat, 07 Nov 2020 08:02:36 +0100
parents 2a9d304b3a82
children d9473bd5ed43
line wrap: on
line diff
--- a/OrthancFramework/UnitTestsSources/CMakeLists.txt	Fri Nov 06 21:15:09 2020 +0100
+++ b/OrthancFramework/UnitTestsSources/CMakeLists.txt	Sat Nov 07 08:02:36 2020 +0100
@@ -28,7 +28,12 @@
 set(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
 set(STATIC_BUILD OFF CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
 set(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
+
 set(USE_GOOGLE_TEST_DEBIAN_PACKAGE OFF CACHE BOOL "Use the sources of Google Test shipped with libgtest-dev (Debian only)")
+set(USE_SYSTEM_BOOST ON CACHE BOOL "Use the system version of Boost")
+set(USE_SYSTEM_GOOGLE_TEST ON CACHE BOOL "Use the system version of Google Test")
+
+set(BOOST_LOCALE_BACKEND "libiconv" CACHE STRING "Back-end for locales that is used by Boost (can be \"gcc\", \"libiconv\", \"icu\", or \"wconv\" on Windows)")
 set(USE_CXX11 OFF CACHE BOOL "Whether to enable compiler support for C++11")
 
 if (UNIT_TESTS_WITH_HTTP_CONNEXIONS)