diff OrthancServer/CMakeLists.txt @ 5569:738f80622e91 find-refactoring

merge default -> find-refactoring
author Alain Mazy <am@orthanc.team>
date Thu, 25 Apr 2024 17:07:33 +0200
parents 12d8a1a266e9 0b18690c1935
children 9e74e761b108
line wrap: on
line diff
--- a/OrthancServer/CMakeLists.txt	Thu Apr 25 09:22:07 2024 +0200
+++ b/OrthancServer/CMakeLists.txt	Thu Apr 25 17:07:33 2024 +0200
@@ -500,6 +500,10 @@
     
     ${CMAKE_SOURCE_DIR}/../OrthancFramework/Resources/ThirdParty/base64/base64.cpp
     ${CMAKE_SOURCE_DIR}/../OrthancFramework/Resources/ThirdParty/md5/md5.c
+
+    # the orthanc framework sources
+    ${ORTHANC_CORE_SOURCES}
+
     Plugins/Samples/Common/OrthancPluginCppWrapper.cpp
     )
 
@@ -524,6 +528,8 @@
 
   DefineSourceBasenameForTarget(PluginsDependencies)
 
+  target_include_directories(PluginsDependencies PUBLIC ${CMAKE_SOURCE_DIR}/../OrthancFramework/Sources)
+
   # Add the "-fPIC" option as this static library must be embedded
   # inside shared libraries (important on UNIX)
   set_target_properties(