diff CMakeLists.txt @ 26:6ba765ecf3db

compiling openssl
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 28 Aug 2012 15:10:02 +0200
parents 166664f0f860
children 042ac60f5bf9
line wrap: on
line diff
--- a/CMakeLists.txt	Tue Aug 28 11:20:49 2012 +0200
+++ b/CMakeLists.txt	Tue Aug 28 15:10:02 2012 +0200
@@ -28,6 +28,7 @@
   ${CMAKE_SOURCE_DIR}/Resources/md5/md5.c
   ${CMAKE_SOURCE_DIR}/Resources/base64/base64.cpp
   )
+
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DcmtkConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
@@ -38,9 +39,15 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibCurlConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibPngConfiguration.cmake)
 
+if (${ENABLE_SSL})
+  include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
+endif()
+
 
 if (${CMAKE_COMPILER_IS_GNUCXX})
-  set(CMAKE_C_FLAGS "-Wall -pedantic -Wno-implicit-function-declaration")  # --std=c99 makes libcurl not to compile
+  set(CMAKE_C_FLAGS "-Wall -Wno-long-long -Wno-implicit-function-declaration")  
+  # --std=c99 makes libcurl not to compile
+  # -pedantic gives a lot of warnings on OpenSSL 
   set(CMAKE_CXX_FLAGS "-Wall -pedantic -Wno-long-long -Wno-variadic-macros")
 elseif (${MSVC})
   # http://stackoverflow.com/a/6510446
@@ -184,7 +191,6 @@
 TARGET_LINK_LIBRARIES(Palantir ServerLibrary CoreLibrary)
 TARGET_LINK_LIBRARIES(UnitTests ServerLibrary CoreLibrary)
 
-
 find_package(Doxygen)
 if (DOXYGEN_FOUND)
   configure_file(