diff OrthancServer/Plugins/Samples/StorageArea/CMakeLists.txt @ 4514:5b929e6b3c36

removal of "dicom-as-json" attachments
author Sebastien Jodogne <s.jodogne@gmail.com>
date Tue, 16 Feb 2021 12:18:41 +0100
parents d9473bd5ed43
children 7053502fbf97
line wrap: on
line diff
--- a/OrthancServer/Plugins/Samples/StorageArea/CMakeLists.txt	Fri Feb 12 12:13:19 2021 +0100
+++ b/OrthancServer/Plugins/Samples/StorageArea/CMakeLists.txt	Tue Feb 16 12:18:41 2021 +0100
@@ -23,4 +23,12 @@
 
 include(${CMAKE_SOURCE_DIR}/../Common/OrthancPlugins.cmake)
 
+set(USE_LEGACY_API OFF CACHE BOOL "Whether to enable support for read-range")
+
+if (USE_LEGACY_API)
+  add_definitions(-DUSE_LEGACY_API=1)
+else()
+  add_definitions(-DUSE_LEGACY_API=0)
+endif()
+
 add_library(PluginTest SHARED Plugin.cpp)