diff Plugins/Samples/ServeFolders/CMakeLists.txt @ 1323:5a92665dee23

Sample plugin: Serve folders
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 13 Feb 2015 14:28:16 +0100
parents f497a72d9f71
children a761deb85729
line wrap: on
line diff
--- a/Plugins/Samples/ServeFolders/CMakeLists.txt	Fri Feb 13 13:28:01 2015 +0100
+++ b/Plugins/Samples/ServeFolders/CMakeLists.txt	Fri Feb 13 14:28:16 2015 +0100
@@ -2,6 +2,11 @@
 
 project(ServeFolders)
 
+set(ALLOW_DOWNLOADS ON)
+set(USE_SYSTEM_JSONCPP OFF)
+include(../../../Resources/CMake/DownloadPackage.cmake)
+include(../../../Resources/CMake/JsonCppConfiguration.cmake)
+
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
   link_libraries(uuid)
   SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pthread")
@@ -18,10 +23,13 @@
 endif()
 
 include_directories(${CMAKE_SOURCE_DIR}/../../Include/)
-add_library(PluginTest SHARED Plugin.cpp)
+add_library(ServerFolders SHARED 
+  Plugin.cpp
+  ${THIRD_PARTY_SOURCES}
+  )
 
 if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
   # Linking with "pthread" is necessary, otherwise the software crashes
   # http://sourceware.org/bugzilla/show_bug.cgi?id=10652#c17
-  target_link_libraries(PluginTest pthread dl)
+  target_link_libraries(ServerFolders dl rt)
 endif()