diff CMakeLists.txt @ 291:4d7469f72a0b

embedding of dicom dictionaries
author Sebastien Jodogne <s.jodogne@gmail.com>
date Fri, 14 Dec 2012 15:15:48 +0100
parents ffd98d2f0b91
children b79b9343ff89
line wrap: on
line diff
--- a/CMakeLists.txt	Fri Dec 14 11:24:24 2012 +0100
+++ b/CMakeLists.txt	Fri Dec 14 15:15:48 2012 +0100
@@ -43,26 +43,6 @@
   SET(STANDALONE_BUILD ON)
 endif()
 
-if (${STANDALONE_BUILD})
-  # We embed all the resources in the binaries for standalone builds
-  add_definitions(-DORTHANC_STANDALONE=1)
-  EmbedResources(
-    PREPARE_DATABASE OrthancServer/PrepareDatabase.sql
-    ORTHANC_EXPLORER OrthancExplorer
-    CONFIGURATION_SAMPLE Resources/Configuration.json
-    )
-else()
-  add_definitions(
-    -DORTHANC_STANDALONE=0
-    -DORTHANC_PATH=\"${CMAKE_SOURCE_DIR}\"
-    )
-  EmbedResources(
-    PREPARE_DATABASE OrthancServer/PrepareDatabase.sql
-    CONFIGURATION_SAMPLE Resources/Configuration.json
-    )
-endif()
-
-
 # Prepare the third-party dependencies
 SET(THIRD_PARTY_SOURCES
   ${CMAKE_SOURCE_DIR}/Resources/md5/md5.c
@@ -93,6 +73,32 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibPngConfiguration.cmake)
 
 
+# Prepare the embedded files
+set(EMBEDDED_FILES
+  PREPARE_DATABASE ${CMAKE_CURRENT_SOURCE_DIR}/OrthancServer/PrepareDatabase.sql
+  CONFIGURATION_SAMPLE ${CMAKE_CURRENT_SOURCE_DIR}/Resources/Configuration.json
+  )
+
+if (${STANDALONE_BUILD})
+  # We embed all the resources in the binaries for standalone builds
+  add_definitions(-DORTHANC_STANDALONE=1)
+  EmbedResources(
+    ${EMBEDDED_FILES}
+    ORTHANC_EXPLORER ${CMAKE_CURRENT_SOURCE_DIR}/OrthancExplorer
+    ${DCMTK_DICTIONARIES}
+    )
+else()
+  add_definitions(
+    -DORTHANC_STANDALONE=0
+    -DORTHANC_PATH=\"${CMAKE_SOURCE_DIR}\"
+    )
+  EmbedResources(
+    ${EMBEDDED_FILES}
+    )
+endif()
+
+
+
 # The main instructions to build the Orthanc binaries
 add_library(CoreLibrary
   STATIC