diff OrthancCppClient/CMakeLists.txt @ 57:4bc019d2f969 orthanc-renaming

renaming
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sun, 16 Sep 2012 09:22:48 +0200
parents PalanthirCppClient/CMakeLists.txt@9beb9b8582f7
children 77aec9be0a51
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/OrthancCppClient/CMakeLists.txt	Sun Sep 16 09:22:48 2012 +0200
@@ -0,0 +1,35 @@
+# Mini-project to check whether "PalanthirCppClient" can compile in a
+# standalone fashion
+
+cmake_minimum_required(VERSION 2.8)
+
+project(PalanthirCppClientTest)
+
+SET(STATIC_BUILD OFF)
+
+include(${CMAKE_SOURCE_DIR}/../Resources/CMake/DownloadPackage.cmake)
+include(${CMAKE_SOURCE_DIR}/../Resources/CMake/JsonCppConfiguration.cmake)
+include(${CMAKE_SOURCE_DIR}/../Resources/CMake/LibCurlConfiguration.cmake)
+
+if (${CMAKE_COMPILER_IS_GNUCXX})
+  set(CMAKE_C_FLAGS "-Wall -pedantic -Wno-implicit-function-declaration")  # --std=c99 makes libcurl not to compile
+  set(CMAKE_CXX_FLAGS "-Wall -pedantic -Wno-long-long -Wno-variadic-macros")
+  set(CMAKE_EXE_LINKER_FLAGS "-Wl,--as-needed")
+  set(CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined")
+elseif (${MSVC})
+  add_definitions(-D_CRT_SECURE_NO_WARNINGS=1)  
+endif()
+
+add_library(PalanthirCppClient
+  SHARED
+
+  ${THIRD_PARTY_SOURCES}
+  HttpException.cpp
+  HttpClient.cpp
+  )
+
+add_executable(Test
+  main.cpp
+  )
+
+target_link_libraries(Test PalanthirCppClient)