diff CMakeLists.txt @ 57:4bc019d2f969 orthanc-renaming

renaming
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sun, 16 Sep 2012 09:22:48 +0200
parents e0cac5540668
children 297bad4e1019
line wrap: on
line diff
--- a/CMakeLists.txt	Sun Sep 16 09:21:12 2012 +0200
+++ b/CMakeLists.txt	Sun Sep 16 09:22:48 2012 +0200
@@ -1,6 +1,6 @@
 cmake_minimum_required(VERSION 2.8)
 
-project(Palanthir)
+project(Orthanc)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/AutoGeneratedCode.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DownloadPackage.cmake)
 include(CheckIncludeFiles)
@@ -30,10 +30,10 @@
   )
 
 if (${ENABLE_SSL})
-  add_definitions(-DPALANTHIR_SSL_ENABLED=1)
+  add_definitions(-DORTHANC_SSL_ENABLED=1)
   include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
 else()
-  add_definitions(-DPALANTHIR_SSL_ENABLED=0)
+  add_definitions(-DORTHANC_SSL_ENABLED=0)
 endif()
 
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
@@ -98,29 +98,29 @@
 
 
 if (${STATIC_BUILD})
-  add_definitions(-DPALANTHIR_STATIC=1)
+  add_definitions(-DORTHANC_STATIC=1)
 else()
-  add_definitions(-DPALANTHIR_STATIC=0)
+  add_definitions(-DORTHANC_STATIC=0)
 endif()
 
 if (${STANDALONE_BUILD})
   add_definitions(
-    -DPALANTHIR_STANDALONE=1
+    -DORTHANC_STANDALONE=1
     )
 
   EmbedResources(
-    PREPARE_DATABASE PalanthirServer/PrepareDatabase.sql
-    PALANTHIR_EXPLORER PalanthirExplorer
+    PREPARE_DATABASE OrthancServer/PrepareDatabase.sql
+    ORTHANC_EXPLORER OrthancExplorer
     )
 
 else()
   add_definitions(
-    -DPALANTHIR_STANDALONE=0
-    -DPALANTHIR_PATH=\"${CMAKE_SOURCE_DIR}\"
+    -DORTHANC_STANDALONE=0
+    -DORTHANC_PATH=\"${CMAKE_SOURCE_DIR}\"
     )
 
   EmbedResources(
-    PREPARE_DATABASE PalanthirServer/PrepareDatabase.sql
+    PREPARE_DATABASE OrthancServer/PrepareDatabase.sql
     )
 endif()
 
@@ -133,7 +133,7 @@
   Core/ChunkedBuffer.cpp
   Core/Compression/BufferCompressor.cpp
   Core/Compression/ZlibCompressor.cpp
-  Core/PalanthirException.cpp
+  Core/OrthancException.cpp
   Core/DicomFormat/DicomArray.cpp
   Core/DicomFormat/DicomMap.cpp
   Core/DicomFormat/DicomTag.cpp
@@ -154,33 +154,33 @@
   Core/Toolbox.cpp
   Core/Uuid.cpp
 
-  PalanthirCppClient/HttpClient.cpp
-  PalanthirCppClient/HttpException.cpp
+  OrthancCppClient/HttpClient.cpp
+  OrthancCppClient/HttpException.cpp
   )  
 
 add_library(ServerLibrary
-  PalanthirServer/DicomIntegerPixelAccessor.cpp
-  PalanthirServer/DicomProtocol/DicomFindAnswers.cpp
-  PalanthirServer/DicomProtocol/DicomServer.cpp
-  PalanthirServer/DicomProtocol/DicomUserConnection.cpp
-  PalanthirServer/FromDcmtkBridge.cpp
-  PalanthirServer/Internals/CommandDispatcher.cpp
-  PalanthirServer/Internals/FindScp.cpp
-  PalanthirServer/Internals/MoveScp.cpp
-  PalanthirServer/Internals/StoreScp.cpp
-  PalanthirServer/PalanthirInitialization.cpp
-  PalanthirServer/PalanthirRestApi.cpp
-  PalanthirServer/ServerIndex.cpp
-  PalanthirServer/ToDcmtkBridge.cpp
-  PalanthirServer/ToDcmtkBridge.cpp
-  PalanthirServer/DicomIntegerPixelAccessor.cpp
+  OrthancServer/DicomIntegerPixelAccessor.cpp
+  OrthancServer/DicomProtocol/DicomFindAnswers.cpp
+  OrthancServer/DicomProtocol/DicomServer.cpp
+  OrthancServer/DicomProtocol/DicomUserConnection.cpp
+  OrthancServer/FromDcmtkBridge.cpp
+  OrthancServer/Internals/CommandDispatcher.cpp
+  OrthancServer/Internals/FindScp.cpp
+  OrthancServer/Internals/MoveScp.cpp
+  OrthancServer/Internals/StoreScp.cpp
+  OrthancServer/OrthancInitialization.cpp
+  OrthancServer/OrthancRestApi.cpp
+  OrthancServer/ServerIndex.cpp
+  OrthancServer/ToDcmtkBridge.cpp
+  OrthancServer/ToDcmtkBridge.cpp
+  OrthancServer/DicomIntegerPixelAccessor.cpp
   )
 
 # Ensure autogenerated code is built before building ServerLibrary
 add_dependencies(ServerLibrary CoreLibrary)
 
-add_executable(Palanthir
-  PalanthirServer/main.cpp
+add_executable(Orthanc
+  OrthancServer/main.cpp
   )
 
 add_executable(UnitTests
@@ -191,17 +191,17 @@
   UnitTests/Versions.cpp
   )
 
-TARGET_LINK_LIBRARIES(Palanthir ServerLibrary CoreLibrary)
+TARGET_LINK_LIBRARIES(Orthanc ServerLibrary CoreLibrary)
 TARGET_LINK_LIBRARIES(UnitTests ServerLibrary CoreLibrary)
 
 find_package(Doxygen)
 if (DOXYGEN_FOUND)
   configure_file(
-    ${CMAKE_SOURCE_DIR}/Resources/Palanthir.doxygen
-    ${CMAKE_CURRENT_BINARY_DIR}/Palanthir.doxygen
+    ${CMAKE_SOURCE_DIR}/Resources/Orthanc.doxygen
+    ${CMAKE_CURRENT_BINARY_DIR}/Orthanc.doxygen
     @ONLY)
   add_custom_target(doc
-    ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Palanthir.doxygen
+    ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Orthanc.doxygen
     WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
     COMMENT "Generating API documentation with Doxygen" VERBATIM
     )