diff CMakeLists.txt @ 3074:495c5edce708 db-changes

new extension for database plugin SDK: lookupResources
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 02 Jan 2019 15:50:44 +0100
parents 2df061cf2fec
children 1a75595d8e44
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jan 02 13:44:18 2019 +0100
+++ b/CMakeLists.txt	Wed Jan 02 15:50:44 2019 +0100
@@ -124,6 +124,8 @@
 
 
 if (ENABLE_PLUGINS)
+  include_directories(${CMAKE_SOURCE_DIR}/Plugins/Include)
+
   list(APPEND ORTHANC_SERVER_SOURCES
     Plugins/Engine/OrthancPluginDatabase.cpp
     Plugins/Engine/OrthancPlugins.cpp
@@ -229,8 +231,6 @@
 endif()
 
 
-include_directories(${CMAKE_SOURCE_DIR}/Plugins/Include)
-
 add_definitions(
   -DORTHANC_BUILD_UNIT_TESTS=1
   -DORTHANC_ENABLE_LOGGING_PLUGIN=0