diff CMakeLists.txt @ 2379:4900688827a8

reorganization in CMake
author Sebastien Jodogne <s.jodogne@gmail.com>
date Mon, 28 Aug 2017 18:07:03 +0200
parents 32bea64e070b
children 96b3ec054b69
line wrap: on
line diff
--- a/CMakeLists.txt	Mon Aug 28 15:02:27 2017 +0200
+++ b/CMakeLists.txt	Mon Aug 28 18:07:03 2017 +0200
@@ -305,13 +305,19 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibPngConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibJpegConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LuaConfiguration.cmake)
-include(${CMAKE_SOURCE_DIR}/Resources/CMake/PugixmlConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/SQLiteConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/ZlibConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibIconvConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
 
+if (USE_PUGIXML)
+  include(${CMAKE_SOURCE_DIR}/Resources/CMake/PugixmlConfiguration.cmake)
+  add_definitions(-DORTHANC_ENABLE_PUGIXML=1)
+else()
+  add_definitions(-DORTHANC_ENABLE_PUGIXML=0)  
+endif()
+
 if (ENABLE_CIVETWEB)
   include(${CMAKE_SOURCE_DIR}/Resources/CMake/CivetwebConfiguration.cmake)
   add_definitions(
@@ -444,6 +450,8 @@
   -DORTHANC_ENABLE_LOGGING_PLUGIN=0
   -DORTHANC_ENABLE_LUA=1
   -DORTHANC_ENABLE_MD5=1
+  -DORTHANC_ENABLE_PNG=1
+  -DORTHANC_HAS_EMBEDDED_RESOURCES=1
   -DORTHANC_MAXIMUM_TAG_LENGTH=256
   -DORTHANC_SANDBOXED=0