diff CMakeLists.txt @ 101:428784e59dcd

trying to use log4cplus
author jodogne
date Wed, 03 Oct 2012 11:44:46 +0200
parents 27dc762e3dc8
children 7593b57dc1bf
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Oct 03 09:33:25 2012 +0200
+++ b/CMakeLists.txt	Wed Oct 03 11:44:46 2012 +0200
@@ -4,6 +4,7 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/AutoGeneratedCode.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DownloadPackage.cmake)
 include(CheckIncludeFiles)
+include(CheckIncludeFileCXX)
 
 SET(STATIC_BUILD ON CACHE BOOL "Static build of the third-party libraries (necessary for Windows)")
 SET(STANDALONE_BUILD OFF CACHE BOOL "Standalone build (necessary for cross-compilation or binary releases)")
@@ -20,7 +21,7 @@
   CHECK_INCLUDE_FILES(uuid/uuid.h HAVE_UUID_H)
 endif()
 
-if (NOT ${HAVE_UUID_H})
+if (NOT HAVE_UUID_H)
   message(FATAL_ERROR "Please install the uuid-dev package")
 endif()
 
@@ -39,6 +40,7 @@
 
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DcmtkConfiguration.cmake)
+include(${CMAKE_SOURCE_DIR}/Resources/CMake/Log4CPlusConfiguration.cmake) # Must be after DcmtkConfiguration
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/MongooseConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/ZlibConfiguration.cmake)
@@ -46,7 +48,6 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/JsonCppConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibCurlConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibPngConfiguration.cmake)
-include(${CMAKE_SOURCE_DIR}/Resources/CMake/Log4CPlusConfiguration.cmake)
 
 
 if (${CMAKE_COMPILER_IS_GNUCXX})
@@ -171,6 +172,7 @@
   Core/HttpServer/MongooseServer.cpp
   Core/MultiThreading/BagOfRunnablesBySteps.cpp
   Core/PngWriter.cpp
+  Core/Logging.cpp
   Core/SQLite/Connection.cpp
   Core/SQLite/FunctionContext.cpp
   Core/SQLite/Statement.cpp
@@ -189,6 +191,7 @@
   OrthancServer/DicomProtocol/DicomServer.cpp
   OrthancServer/DicomProtocol/DicomUserConnection.cpp
   OrthancServer/FromDcmtkBridge.cpp
+  OrthancServer/Internals/DcmtkLogging.cpp
   OrthancServer/Internals/CommandDispatcher.cpp
   OrthancServer/Internals/FindScp.cpp
   OrthancServer/Internals/MoveScp.cpp