diff OrthancFramework/SharedLibrary/CMakeLists.txt @ 4067:3d7afb01dc14 framework

fix
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 11 Jun 2020 18:57:03 +0200
parents 3a59a021b5de
children d6b7fb0f9652
line wrap: on
line diff
--- a/OrthancFramework/SharedLibrary/CMakeLists.txt	Thu Jun 11 18:43:14 2020 +0200
+++ b/OrthancFramework/SharedLibrary/CMakeLists.txt	Thu Jun 11 18:57:03 2020 +0200
@@ -53,6 +53,9 @@
   set(BOOST_LOCALE_BACKEND "libiconv")
   set(ORTHANC_SANDBOXED ON)
 
+  # Will be used by "../Resources/CMake/EmscriptenParameters.cmake"
+  set(WASM_FLAGS "-s SIDE_MODULE=1 -s EXPORT_ALL=1")
+
 else()
   # Enable all the remaining modules for other targets
   set(ENABLE_CRYPTO_OPTIONS ON)