diff Resources/Samples/OrthancClient/Vtk/CMakeLists.txt @ 590:3237eea24487

renaming
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 02 Oct 2013 15:01:02 +0200
parents Resources/Samples/OrthancCppClientStandalone/Vtk/CMakeLists.txt@7f9467b5f33b
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Resources/Samples/OrthancClient/Vtk/CMakeLists.txt	Wed Oct 02 15:01:02 2013 +0200
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Vtk)
+
+find_package(VTK REQUIRED)
+include(${VTK_USE_FILE})
+
+add_executable(Test
+  main.cpp
+  )
+
+# Linking with "pthread" is necessary, otherwise the software crashes
+# http://sourceware.org/bugzilla/show_bug.cgi?id=10652#c17
+target_link_libraries(Test pthread dl)
+
+if(VTK_LIBRARIES)
+  target_link_libraries(Test ${VTK_LIBRARIES})
+else()
+  target_link_libraries(Test vtkHybrid vtkVolumeRendering)
+endif()