diff CMakeLists.txt @ 79:297bad4e1019

refactoring
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 20 Sep 2012 13:47:54 +0200
parents 4bc019d2f969
children 0ec5e2e327b1
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Sep 20 13:41:55 2012 +0200
+++ b/CMakeLists.txt	Thu Sep 20 13:47:54 2012 +0200
@@ -137,6 +137,7 @@
   Core/DicomFormat/DicomArray.cpp
   Core/DicomFormat/DicomMap.cpp
   Core/DicomFormat/DicomTag.cpp
+  Core/DicomFormat/DicomIntegerPixelAccessor.cpp
   Core/FileStorage.cpp
   Core/HttpServer/EmbeddedResourceHttpHandler.cpp
   Core/HttpServer/FilesystemHttpHandler.cpp
@@ -159,7 +160,6 @@
   )  
 
 add_library(ServerLibrary
-  OrthancServer/DicomIntegerPixelAccessor.cpp
   OrthancServer/DicomProtocol/DicomFindAnswers.cpp
   OrthancServer/DicomProtocol/DicomServer.cpp
   OrthancServer/DicomProtocol/DicomUserConnection.cpp
@@ -172,8 +172,6 @@
   OrthancServer/OrthancRestApi.cpp
   OrthancServer/ServerIndex.cpp
   OrthancServer/ToDcmtkBridge.cpp
-  OrthancServer/ToDcmtkBridge.cpp
-  OrthancServer/DicomIntegerPixelAccessor.cpp
   )
 
 # Ensure autogenerated code is built before building ServerLibrary