diff Resources/Samples/Plugins/Basic/CMakeLists.txt @ 886:29087d728e0a plugins

plugin sample
author Sebastien Jodogne <s.jodogne@gmail.com>
date Sat, 14 Jun 2014 18:50:14 +0200
parents
children 690aeb4cb899
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Resources/Samples/Plugins/Basic/CMakeLists.txt	Sat Jun 14 18:50:14 2014 +0200
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.8)
+
+project(Basic)
+
+add_library(PluginTest SHARED Plugin.c)
+
+if (${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+  # Linking with "pthread" is necessary, otherwise the software crashes
+  # http://sourceware.org/bugzilla/show_bug.cgi?id=10652#c17
+  target_link_libraries(PluginTest pthread dl)
+endif()