diff CMakeLists.txt @ 707:203157cb4fde

unit tests of httpclient
author Sebastien Jodogne <s.jodogne@gmail.com>
date Thu, 13 Feb 2014 14:37:35 +0100
parents 72dc919a028c
children 8f62e8d5a384
line wrap: on
line diff
--- a/CMakeLists.txt	Thu Feb 13 12:46:39 2014 +0100
+++ b/CMakeLists.txt	Thu Feb 13 14:37:35 2014 +0100
@@ -17,6 +17,7 @@
 SET(BUILD_CLIENT_LIBRARY ON CACHE BOOL "Build the client library")
 SET(DCMTK_DICTIONARY_DIR "/usr/share/dcmtk" CACHE PATH "Directory containing the DCMTK dictionaries \"dicom.dic\" and \"private.dic\" (only when using system version of DCMTK)") 
 SET(ALLOW_DOWNLOADS OFF CACHE BOOL "Allow CMake to download packages")
+SET(UNIT_TESTS_WITH_HTTP_CONNEXIONS ON CACHE BOOL "Allow unit tests to make HTTP requests")
 
 # Advanced parameters to fine-tune linking against system libraries
 SET(USE_SYSTEM_JSONCPP ON CACHE BOOL "Use the system version of JsonCpp")
@@ -241,6 +242,12 @@
 ## Build the unit tests
 #####################################################################
 
+if (UNIT_TESTS_WITH_HTTP_CONNEXIONS)
+  add_definitions(-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=1)
+else()
+  add_definitions(-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=0)
+endif()
+
 add_definitions(-DORTHANC_BUILD_UNIT_TESTS=1)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
 add_executable(UnitTests