diff CMakeLists.txt @ 1414:0a67a502c90f

fixes
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 03 Jun 2015 21:14:05 +0200
parents 98fa856b4f8f
children 97268448bdfc
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jun 03 17:38:39 2015 +0200
+++ b/CMakeLists.txt	Wed Jun 03 21:14:05 2015 +0200
@@ -223,18 +223,6 @@
 ## Inclusion of third-party dependencies
 #####################################################################
 
-# Configuration of the standalone builds
-if (CMAKE_CROSSCOMPILING)
-  # Cross-compilation implies the standalone build
-  SET(STANDALONE_BUILD ON)
-endif()
-
-# Prepare the third-party dependencies
-SET(THIRD_PARTY_SOURCES
-  ${CMAKE_SOURCE_DIR}/Resources/ThirdParty/md5/md5.c
-  ${CMAKE_SOURCE_DIR}/Resources/ThirdParty/base64/base64.cpp
-  )
-
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleLogConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DcmtkConfiguration.cmake)
@@ -248,7 +236,7 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/PugixmlConfiguration.cmake)
 
 
-if (${ENABLE_SSL})
+if (ENABLE_SSL)
   add_definitions(-DORTHANC_SSL_ENABLED=1)
   include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
 else()
@@ -275,7 +263,7 @@
 ## Autogeneration of files
 #####################################################################
 
-if (${STANDALONE_BUILD})
+if (STANDALONE_BUILD)
   # We embed all the resources in the binaries for standalone builds
   add_definitions(-DORTHANC_STANDALONE=1)
   EmbedResources(
@@ -300,7 +288,7 @@
 #####################################################################
 
 # Setup precompiled headers for Microsoft Visual Studio
-if (${MSVC})
+if (MSVC)
   add_definitions(-DORTHANC_USE_PRECOMPILED_HEADERS=1)
 
   ADD_VISUAL_STUDIO_PRECOMPILED_HEADERS(
@@ -326,13 +314,24 @@
 
 add_library(CoreLibrary
   STATIC
+  ${ORTHANC_CORE_SOURCES}
   ${AUTOGENERATED_SOURCES}
-  ${THIRD_PARTY_SOURCES}
+
   ${CURL_SOURCES}
-  ${ORTHANC_CORE_SOURCES}
+  ${ZLIB_SOURCES}
+  ${MONGOOSE_SOURCES}
+  ${JSONCPP_SOURCES}
+  ${BOOST_SOURCES}
+  ${SQLITE_SOURCES}
+  ${LIBPNG_SOURCES}
+  ${PUGIXML_SOURCES}
+
+  ${CMAKE_SOURCE_DIR}/Resources/ThirdParty/md5/md5.c
+  ${CMAKE_SOURCE_DIR}/Resources/ThirdParty/base64/base64.cpp
   )  
 
 
+
 #####################################################################
 ## Build the Orthanc server
 #####################################################################
@@ -398,7 +397,7 @@
 add_library(
   ServeFolders SHARED 
   Plugins/Samples/ServeFolders/Plugin.cpp
-  ${THIRD_PARTY_SOURCES}
+  ${JSONCPP_SOURCES}
   )
 
 set_target_properties(