diff CMakeLists.txt @ 48:0a04c70747d9

renaming
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 05 Sep 2012 15:36:45 +0200
parents 042ac60f5bf9
children e0cac5540668
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Sep 05 13:26:06 2012 +0200
+++ b/CMakeLists.txt	Wed Sep 05 15:36:45 2012 +0200
@@ -1,6 +1,6 @@
 cmake_minimum_required(VERSION 2.8)
 
-project(Palantir)
+project(Palanthir)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/AutoGeneratedCode.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DownloadPackage.cmake)
 include(CheckIncludeFiles)
@@ -30,10 +30,10 @@
   )
 
 if (${ENABLE_SSL})
-  add_definitions(-DPALANTIR_SSL_ENABLED=1)
+  add_definitions(-DPALANTHIR_SSL_ENABLED=1)
   include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
 else()
-  add_definitions(-DPALANTIR_SSL_ENABLED=0)
+  add_definitions(-DPALANTHIR_SSL_ENABLED=0)
 endif()
 
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
@@ -98,29 +98,29 @@
 
 
 if (${STATIC_BUILD})
-  add_definitions(-DPALANTIR_STATIC=1)
+  add_definitions(-DPALANTHIR_STATIC=1)
 else()
-  add_definitions(-DPALANTIR_STATIC=0)
+  add_definitions(-DPALANTHIR_STATIC=0)
 endif()
 
 if (${STANDALONE_BUILD})
   add_definitions(
-    -DPALANTIR_STANDALONE=1
+    -DPALANTHIR_STANDALONE=1
     )
 
   EmbedResources(
-    PREPARE_DATABASE PalantirServer/PrepareDatabase.sql
-    PALANTIR_EXPLORER PalantirExplorer
+    PREPARE_DATABASE PalanthirServer/PrepareDatabase.sql
+    PALANTHIR_EXPLORER PalanthirExplorer
     )
 
 else()
   add_definitions(
-    -DPALANTIR_STANDALONE=0
-    -DPALANTIR_PATH=\"${CMAKE_SOURCE_DIR}\"
+    -DPALANTHIR_STANDALONE=0
+    -DPALANTHIR_PATH=\"${CMAKE_SOURCE_DIR}\"
     )
 
   EmbedResources(
-    PREPARE_DATABASE PalantirServer/PrepareDatabase.sql
+    PREPARE_DATABASE PalanthirServer/PrepareDatabase.sql
     )
 endif()
 
@@ -133,7 +133,7 @@
   Core/ChunkedBuffer.cpp
   Core/Compression/BufferCompressor.cpp
   Core/Compression/ZlibCompressor.cpp
-  Core/PalantirException.cpp
+  Core/PalanthirException.cpp
   Core/DicomFormat/DicomArray.cpp
   Core/DicomFormat/DicomMap.cpp
   Core/DicomFormat/DicomTag.cpp
@@ -154,33 +154,33 @@
   Core/Toolbox.cpp
   Core/Uuid.cpp
 
-  PalantirCppClient/HttpClient.cpp
-  PalantirCppClient/HttpException.cpp
+  PalanthirCppClient/HttpClient.cpp
+  PalanthirCppClient/HttpException.cpp
   )  
 
 add_library(ServerLibrary
-  PalantirServer/DicomIntegerPixelAccessor.cpp
-  PalantirServer/DicomProtocol/DicomFindAnswers.cpp
-  PalantirServer/DicomProtocol/DicomServer.cpp
-  PalantirServer/DicomProtocol/DicomUserConnection.cpp
-  PalantirServer/FromDcmtkBridge.cpp
-  PalantirServer/Internals/CommandDispatcher.cpp
-  PalantirServer/Internals/FindScp.cpp
-  PalantirServer/Internals/MoveScp.cpp
-  PalantirServer/Internals/StoreScp.cpp
-  PalantirServer/PalantirInitialization.cpp
-  PalantirServer/PalantirRestApi.cpp
-  PalantirServer/ServerIndex.cpp
-  PalantirServer/ToDcmtkBridge.cpp
-  PalantirServer/ToDcmtkBridge.cpp
-  PalantirServer/DicomIntegerPixelAccessor.cpp
+  PalanthirServer/DicomIntegerPixelAccessor.cpp
+  PalanthirServer/DicomProtocol/DicomFindAnswers.cpp
+  PalanthirServer/DicomProtocol/DicomServer.cpp
+  PalanthirServer/DicomProtocol/DicomUserConnection.cpp
+  PalanthirServer/FromDcmtkBridge.cpp
+  PalanthirServer/Internals/CommandDispatcher.cpp
+  PalanthirServer/Internals/FindScp.cpp
+  PalanthirServer/Internals/MoveScp.cpp
+  PalanthirServer/Internals/StoreScp.cpp
+  PalanthirServer/PalanthirInitialization.cpp
+  PalanthirServer/PalanthirRestApi.cpp
+  PalanthirServer/ServerIndex.cpp
+  PalanthirServer/ToDcmtkBridge.cpp
+  PalanthirServer/ToDcmtkBridge.cpp
+  PalanthirServer/DicomIntegerPixelAccessor.cpp
   )
 
 # Ensure autogenerated code is built before building ServerLibrary
 add_dependencies(ServerLibrary CoreLibrary)
 
-add_executable(Palantir
-  PalantirServer/main.cpp
+add_executable(Palanthir
+  PalanthirServer/main.cpp
   )
 
 add_executable(UnitTests
@@ -191,17 +191,17 @@
   UnitTests/Versions.cpp
   )
 
-TARGET_LINK_LIBRARIES(Palantir ServerLibrary CoreLibrary)
+TARGET_LINK_LIBRARIES(Palanthir ServerLibrary CoreLibrary)
 TARGET_LINK_LIBRARIES(UnitTests ServerLibrary CoreLibrary)
 
 find_package(Doxygen)
 if (DOXYGEN_FOUND)
   configure_file(
-    ${CMAKE_SOURCE_DIR}/Resources/Palantir.doxygen
-    ${CMAKE_CURRENT_BINARY_DIR}/Palantir.doxygen
+    ${CMAKE_SOURCE_DIR}/Resources/Palanthir.doxygen
+    ${CMAKE_CURRENT_BINARY_DIR}/Palanthir.doxygen
     @ONLY)
   add_custom_target(doc
-    ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Palantir.doxygen
+    ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Palanthir.doxygen
     WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
     COMMENT "Generating API documentation with Doxygen" VERBATIM
     )