diff CMakeLists.txt @ 29:042ac60f5bf9

simplified build of curl
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 29 Aug 2012 15:27:13 +0200
parents 6ba765ecf3db
children 0a04c70747d9
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Aug 29 11:07:55 2012 +0200
+++ b/CMakeLists.txt	Wed Aug 29 15:27:13 2012 +0200
@@ -29,6 +29,13 @@
   ${CMAKE_SOURCE_DIR}/Resources/base64/base64.cpp
   )
 
+if (${ENABLE_SSL})
+  add_definitions(-DPALANTIR_SSL_ENABLED=1)
+  include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
+else()
+  add_definitions(-DPALANTIR_SSL_ENABLED=0)
+endif()
+
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/BoostConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/DcmtkConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/GoogleTestConfiguration.cmake)
@@ -39,10 +46,6 @@
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibCurlConfiguration.cmake)
 include(${CMAKE_SOURCE_DIR}/Resources/CMake/LibPngConfiguration.cmake)
 
-if (${ENABLE_SSL})
-  include(${CMAKE_SOURCE_DIR}/Resources/CMake/OpenSslConfiguration.cmake)
-endif()
-
 
 if (${CMAKE_COMPILER_IS_GNUCXX})
   set(CMAKE_C_FLAGS "-Wall -Wno-long-long -Wno-implicit-function-declaration")