diff CMakeLists.txt @ 494:012b63028085

CMake parameter for the location of DCMTK dictionaries
author Sebastien Jodogne <s.jodogne@gmail.com>
date Wed, 17 Jul 2013 13:45:28 +0200
parents c56e9480183a
children 7f7a2d174acb b2b56b4e33b0
line wrap: on
line diff
--- a/CMakeLists.txt	Wed Jul 17 12:48:29 2013 +0200
+++ b/CMakeLists.txt	Wed Jul 17 13:45:28 2013 +0200
@@ -12,6 +12,7 @@
 SET(STANDALONE_BUILD ON CACHE BOOL "Standalone build (all the resources are embedded, necessary for releases)")
 SET(ENABLE_SSL ON CACHE BOOL "Include support for SSL")
 SET(BUILD_UNIT_TESTS ON CACHE BOOL "Build the unit tests")
+SET(DCMTK_DICTIONARY_DIR "/usr/share/dcmtk" CACHE PATH "Directory containing the DCMTK dictionaries \"dicom.dic\" and \"private.dic\" (ignored in standalone builds)") 
 
 # Advanced parameters (for Debian packaging)
 SET(USE_DYNAMIC_JSONCPP OFF CACHE BOOL "Use the dynamic version of JsonCpp (only for Debian sid)")